App Store 2018

Apps moeten vanaf 27 maart iPhone XS Max en iPad Pro 2018 ondersteunen

Apple heeft nieuwe eisen gesteld aan appontwikkelaars. Als ze een update van hun app willen indienen, moet deze geschikt zijn gemaakt voor de iPhone XS Max en de nieuwste iPad Pro's. Dat is goed nieuws voor gebruikers van de nieuwste toestellen.
Benjamin Kuijten - · Laatst bijgewerkt:

Als je net een nieuwe iPhone gekocht hebt, wil je natuurlijk dat alle apps alles uit jouw nieuwe toestel halen. De teleurstelling is dan ook groot als je merkt dat jouw favoriete app nog niet aangepast is voor jouw iPhone. Apple steekt hier een stokje voor, want ze hebben nieuwe eisen opgesteld voor ontwikkelaars. De eisen gelden zowel voor nieuwe apps als voor updates van bestaande apps.

Apps vereisten voor nieuwste toestellen vanaf 27 maart

Ontwikkelaars moeten vanaf 27 maart apps bouwen met de iOS 12.1 SDK. Dat betekent dat apps geoptimaliseerd moeten zijn voor de nieuwste versie van het besturingssysteem. Hierdoor weet je als gebruiker zeker dat een app goed werkt op jouw iPhone en iPad. Bovendien moeten de apps aangepast zijn voor de nieuwe schermen van de iPhone XS Max en de derde generatie iPad Pro 2018 12,9-inch. Dat betekent dus dat alle nieuwe apps en updates die na 27 maart verschijnen, geoptimaliseerd zijn voor de nieuwe beeldverhoudingen. Gek genoeg heeft Apple deze eisen niet gesteld voor de iPhone XR en de 11-inch iPad Pro, maar in de meeste gevallen zullen ook deze toestellen ondersteund worden.

iPad Pro grafisch en met toetsenbord

Ook voor Apple Watch Series 4-gebruikers is er goed nieuws. Vanaf dezelfde datum moeten de apps namelijk gemaakt zijn met watchOS 5.1 en de grotere schermen van de Series 4 ondersteunen. Dat betekent dat apps niet meer in een kleiner kader getoond mogen worden en dat de apps dus van het volledige scherm gebruikmaken. Er zijn nu nog flink wat apps die niet geoptimaliseerd zijn. Willen zij een update doorvoeren, dan moet deze dus vanaf 27 maart aangepast zijn.

Voor mensen met een ouder toestel dat geen ondersteuning biedt voor iOS 12 of watchOS 5 is er nog niets aan de hand. De meeste apps werken ook nog gewoon met iOS 11 of watchOS 4. Oudere iOS-versies als iOS 9 worden wel steeds vaker afgeschreven, waardoor je minimaal iOS 10 nodig hebt.

De nieuwe eisen hebben geen gevolgen voor apps die nu al in de App Store staan. Als een app nu nog geen ondersteuning biedt voor de nieuwe toestellen, blijft deze gewoon te gebruiken en te downloaden. De eisen gelden alleen voor compleet nieuwe apps of updates van bestaande apps. Bestaande nog niet-geoptimaliseerde apps worden dus niet uit de App Store verwijderd.

iOS 12.2 verschijnt volgende week
Ondertussen kun je je ook alvast voorbereiden op de komst van iOS 12.2. Die update verschijnt volgende week, want de verwachte iOS 12.2 releasedatum is 25 maart. De update verschijnt vermoedelijk vlak na de keynote van aanstaande maandag, samen met watchOS 5.2, macOS Mojave 10.14.4 en tvOS 12.2. Heb je nog geen idee wat er nieuw is? Check dan ons artikel met alle iOS 12.2 functies.

Revisiegeschiedenis:

  • 2019 - 21 maart: Opmerking toegevoegd over gevolgen voor huidige apps.

Suggestie hoe we dit artikel kunnen verbeteren? Laat het ons weten!

Informatie

Laatst bijgewerkt 21 maart 2019, 10:45
Bron Bron Apple
Categorie Apps
Onderwerp app store

Reacties zijn gesloten voor dit artikel.