IPhones met dark mode

Apple: ‘Apps moeten vanaf april 2018 aangepast zijn voor iPhone X

Apple heeft ontwikkelaars geïnformeerd dat alle nieuwe apps vanaf april 2018 geschikt moeten zijn voor de iPhone X. Ontwikkelaars moeten dus zorgen dat hun apps rekening houden met de notch en het edge-to-edge scherm.

Vanaf april 2018 apps aangepast voor iPhone X

Precies een maand geleden schreven we dat veel eigen Apple-apps nog niet zijn aangepast voor de iPhone X. Het gaat bijvoorbeeld om veelgebruikte programma’s als iMovie en iTunes Remote, maar ook om meer obscure apps zoals Muziekmemo’s. Sommige apps zijn sinds 2014 en 2016 niet meer bijgewerkt. Voor apps die de komende tijd wél worden bijgewerkt geldt nu dat ze vanaf april geschikt moeten zijn voor de iPhone X en de notch. Ook moeten ze zijn gemaakt met de iOS 11 SDK. Afgelopen jaren heeft Apple deze regels strikt gehanteerd.

Wat zal Apple zelf met de verouderde apps doen? Misschien krijgen ze voorlopig geen update en blijven ze in hun huidige (niet iPhone X-geoptimaliseerde) vorm bestaan, totdat ze ooit nog eens worden bijgewerkt en dan wel aan de regels moeten voldoen.

In de e-mail die vandaag naar ontwikkelaars is gestuurd moedigt Apple de ontwikkelaars aan om met de nieuwste iOS 11-functies bezig te gaan, zoals Core ML, SiriKit en ARKit. Verplicht is dit niet, als ze maar de nieuwste ontwikkeltools van Xcode 9 gebruiken.

Dit had Apple er zelf over te zeggen:

Update your version of Xcode to the latest release of Xcode 9 available on the Mac App Store, which includes the iOS 11 SDK, and build your apps. Starting April 2018, all new iOS apps submitted to the App Store must be built with the iOS 11 SDK. All new apps for iPhone, including universal apps, must support the Super Retina display of iPhone X.

Ontwikkelaars die nog snel hun apps met oude ontwikkeltools willen maken zullen dus moeten opschieten en hun apps tijdig indienen voor het reviewproces. Vanaf april 2018 accepteert Apple ook geen updates voor watchOS 1-apps meer. Vanaf dat moment moeten alle app-updates gemaakt zijn met de watchOS 2 SDK of nieuwer. Nieuwe apps moeten verplicht met de watchOS 4 SDK zijn gemaakt. Daarmee wil Apple zorgen dat alle beschikbare apps native worden en dus minder afhankelijk zijn van de iPhone.

Suggestie hoe we dit artikel kunnen verbeteren? Laat het ons weten!

Informatie

Laatst bijgewerkt 15 februari 2018, 22:12
Categorie iOS
Onderwerpen developers, ontwikkelaars, sdk

Plaats een reactie

Als je een eigen afbeelding bij je reactie wil, moet je je aanmelden bij Gravatar. Daar kun je jouw e-mailadres koppelen aan een afbeelding.

Suggestie hoe we dit artikel kunnen verbeteren?
Laat het ons weten!

    Off-topic reacties worden verwijderd. Linken naar illegale bronnen is niet toegestaan. Respecteer onze algemene gedragsregels. Gebruik voor eventuele spelfouten of andere opmerkingen met betrekking tot het artikel s.v.p. onze artikelrapportage. Voor opmerkingen over ons moderatiebeleid kun je ons contactformulier gebruiken. Reacties met betrekking hierover worden als off-topic beschouwd.